"Unable to delete this tile"

I was making a tilemap for my new game when I accidentally clicked out of the tilemap editor and into the coding interface. When I clicked back into the tilemap editor, three new tiles had appeared. They were repeats of some previous tiles. Here they are :arrow_down:.

image

When I tried to delete them, it said this.


Unable to delete -
This tile is used in your game. Remove all blocks using the tile before deleting.

But, the tile wasn’t in my (blank) tilemap or in my game.

Is there any way to delete these tiles?

My game - https://makecode.com/_c5mg7dXtTYdR

I think it’s because they were made into copies. It says the “Unable to delete” because you have copies of them in you tilemap side bar thing. It’s only a hypothesis. Most likely a bug I assume

Definitely a bug, I’ve filed it in our issue tracker here: https://github.com/microsoft/pxt-arcade/issues/2456

And here’s a share link where I fixed it in your project: https://makecode.com/_KfRKXbiWLhtq

I didn’t delete the tile, but you can delete it now

Thanks!