Ask for string with text - problem

I’ve tried this code but the code doesn’t advance past the asking for a string. No splash appears. Am I doing something wrong? Is it an upgrade issue? Thanks for your help … :slight_smile: :smile:

Have you pressed ‘OK’ in the bottom right corner?

Thanks for the reply. Yes, I’ve tried that. The ok button acts like the a button. There is a demo of the code working at https://arcade.makecode.com/courses/csintro3/intro/user-input unfortunately that code doesn’t work for me.

Hm, I just tested and it seems to be working for me:

If it’s still not, could you send a share link to the code that’s not running so I can check it out?

Hi @jwunderl I tried your code and it doesn’t work. Here’s the link https://makecode.com/_7mYR8X6a9Rh7 I’m starting to think it might be a browser setting.

Just tried your code, Greg, and it seems to be working for me just fine, too.

Are you able to do a screen capture of you running your program? If so, post it here so that we can help you diagnose the problem.

P.S. Joey has mentioned screen2gif for Windows machines and gifox for macOS as two options for saving screen captures as animated GIFs, in case you’re looking for some helpful software. I’ve used screen2gif, and it’s worked really well for me.

Video of using the program: https://drive.google.com/file/d/1urtvSs11TcqK3VTljk8dlzpkf0Ym2I-1/view
Checked browser is uptodate (Chrome).

Remember that the screen in the simulator is not touch-enabled. You can’t “click” on the OK button. You need to navigate to it with the arrow keys, and then press the A button.

Hi @AlexK I see it now. Thank you, of course, that’s how it works. Great to be able to get feedback. Thanks to @jwunderl as well for help on this. Best regards.

1 Like

You’re definitely not the first to run into that. It’s much more obvious when running on hardware, but you get used to the virtual keyboards in the simulator once you see how they work.

We’re always happy to help around here, Greg. Holler anytime!