Microsoft MakeCode

Is tile map ok in beta with 8x8 pixel tiles?

I just ran up some code in beta. The tile map (16x32) in the block looks ok but on screen it’s broken and looks more “blockly” but only in certain places. I’m wondering if some code is assuming 16x16 and ignoring my 8x8 setting?

I’ll add more detail when I’ve got more time to look into this.

The particular feature/bug I’m observing is when a user has used the “classic” tile map from 0.14.9 5.21.14 and then loaded that code into beta beta. There’s one more twist as this involves switching from 16x16 tiles to 8x8 but leaving each tile as a 16x16 image. It looks like 0.14.9 only uses 8x8 of that image but 0.14.54 5.30.19 uses all of it despite the 8x8 setting.

There’s another peculiaritiy here, a thin row of pixels is missing on some of these 16x16 blocks on this smaller res version of the sim screen. I’ve tried to indicate where this occurs with mouse pointer to make it more obvious. Switching to full screen and the thin row isn’t missing, switching back it’s still missing.

arcade-TileMap-Strangeness-8x8

This code fails to load in production (0.16.1) now. It goes into JavaScript view and highlights scene.setTile. The mouseover says: Property 'setTileMap does not exist on typeof scene.` Image below:

arcade-TileMap-Strangeness-8x8-0.16.10-codeloadingproblem

Did you copy and paste that snippet from somewhere, or was that a previous project? Either way it just needs the color coded tilemap for backwards compatibility with the old tilemap blocks, but if this was an old project it should have been added in automatically.

I just tried to load in that png with the code in it from the thread by dragging it into 0.16.1 and it errored :frowning:

Huh, didn’t realize the max version for upgrade rules was exclusive… looks like an off by a few bug here :slight_smile: thanks for catching https://github.com/microsoft/pxt-arcade/blob/master/pxtarget.json#L146 . Fix here https://github.com/microsoft/pxt-arcade/pull/1681, and here’s you game with the package installed: https://makecode.com/_AaC254Mr69sL