Maqueen extensions

Anyone have a solution to “the hex file is not available, please connect to internet and try again”?
The error goes away if I remove the Maqueen libraries, so I guess it’s related to them, but I need the libraries to control the Maqueen robot and its accessories. Can anyone help?

Hi @Sorcerer13 ,

I just did a quick test and it seems to work ok for new projects. Here’s an example: .

Are you using an older project? If so, can you share it? (You could post a link to the project. This page shows how to create a link:

Thanks for the update bsiever.
I’m a bit overwhelmed at the moment - our central heating isn’t working properly, and as we’re both in our 70s with various medical issues, coding for robotics is taking a bit of a back seat.
The project is the one from the DF Robot site - from memory it’s “Lesson 5 Railway Patroller”. I’ll get back with more details and attempt the upload of the project when we’re a bit warmer!!!

The ‘failing’ code is at
Code is at
Incidentally, I’ve just tried it using Google Chrome at tye above address (I normally use Microsoft Edge), and it fails under Chrome too!

try clearing cookies or compiling it in incognito mode, probably wont do anything but its worth a try

Switch to Javascript, expand explorer, Click on the updatearrow of the maqueen extension. You have v 1.3.6 and need v1.7.2

Have fun!

Hi @Sorcerer13 ,

It was using an older version of the extension. Often times old versions of extensions no longer work with the current version of MakeCode.

I think it’ll work with an updated version — it downloads the .hex file, but I didn’t try it on a Maqueen. Here’s the update to try:

And here are the steps that can be done to update extensions yourself:

  1. Switch to the JavaScript view (the slider at the top, middle of the window — select JavaScript rather than Blocks)
  2. On the left side beneath the simulated micro:bit is an Explorer menu. Click the down arrow on the right side to see the full contents.
  3. The menu lists all the libraries and extensions used in the project. To the right of each extension name is a icon of a trash can and a “refresh” (like :arrows_counterclockwise: ) followed by the version of th extension currently in use. Click on the “refresh”/:arrows_counterclockwise: to try to update the extension to the most recent version.

Your non-working version of the project was using v1.3.6 of the extension. Updating it brings it up to >=v1.7.2


Your right - tried both, with no effect (other than having to re-enter a few web site urls).
DF Robots have replied, but a lot of it’s in Chinese! They’re suggesting the url for MakeCode should be ‘’, but this just goes to a github page which doesn’t seem to be of any relevance…

OK - warmed up a bit now, and for the most part I think I’ve got it (except for the “Explorer” bit - still can’t find that on the micro:bit screen!).

For anyone else as dim as I am, I’ve written down the steps below…

Open the editor at

Then either open an existing project or start a new Project.

Then when in a Project I open “Extensions” from the panel on the left.

Then in the next screen in the search box at the top, type in

That seems to load the workable extensions.

Thanks for all your help. I think we finally got there (except I still can’t find the Explorer option!)

Thanks for finding out . I have also spent a couple of hours to get to the bottom of it with no luck…:grinning: