Importing GitHub project does not use latest commit

Hey, I’ve been working on a game here and when I committed 0820285 (“Players can shoot”) it only seemed to import the previous commit 147ca38. (“Create players and change boos color and bullets”) I tried deleting the project and reimporting it, but it only seems to use changes from the third commit. I’ve tried reverting the previous commit that it was importing, but that didn’t work either.

This also happened to another one of my projects, and this is really frustrating as I can’t continue working on a project if it doesn’t show my changes in the editor!

Help would be highly appreciated!

1 Like

Did you try to import and then manually pull?

1 Like

Doesn’t work. It just doesn’t see that last commit. :thinking:

Looking at the list of changed files for the latest commit, it appears only main.ts has been updated, not main.blocks. I’m guessing the editor imports the main.blocks instead and overwrites the TypeScript file. So the real question is why the main.blocks isn’t updating anymore.

1 Like

The commit history in MakeCode shows a commit on the 12th of November at 1:05AM. The commit on GItHub also notes that same date & time. Is this correct? Despite this, the changes don’t seem to load in the blocks.

Can’t you just ask Richard or any moderators for help?

Yea, but it’s 7:05 PM for me. (cause timezones)

I’ve gotten past it anyways by redoing it, but I’ll end up saving a share link before I commit anything…

Don’t want to bother them that much, they have other things to do!

1 Like

Just save manually I’ve never had a problem with that

1 Like