Maximum file size in package is ~64k

I am starting to notice alarming error messages in the Console of Chrome.

pxtapp.js:1 Error: Bad HTTP status code: 404 at https://pxt.azureedge.net/api/gh/cosmoscowboy/wonder-dude?cdn=20201230; message: {“message”:“maximum file size in package is ~64k; file main.blocks; size 289050”}

Does this mean that the blocks file is too large? Do I need to continue coding in Javascript?

After adding some additional code in Blocks, the simulator was showing a blank screen, then a ‘sad’ face icon. I didn’t take a screen shot unfortunately.

Can anyone help me out? Please.

1 Like

Thanks for sharing this, this is a bug. There shouldn’t be any limit on your blocks size.

Some clarifying question if you have time:

  1. Does the error happen only when you play the game via the share link or also in the simulator when editing?
  2. Is it repro’ing with that specific share link or do you have to add blocks to that project before it happens?
  3. Is it repro’ing every time for you or only sometimes?
  4. Also if you happen to get a screenshot of the crash, that would be helpful! There is sometimes a code there.

I’ve filed this issue for now: https://github.com/microsoft/pxt-arcade/issues/2761

Thanks again!

1 Like

Thank you for getting back to me on this.

  1. The error does not occur in the game I shared, when viewing the code, when editing it, or when switching between blocks and Javascript; even after editing both.

This is always happening in my game, which is hosted in Github. I have posted more information in the issue, and a video of the behavior as well.

Thank you! This is really helpful. We’re squashing Arcade bugs now so hopefully it won’t be long before a fix is ready.

2 Likes

Based on my last comment (in GitHub), is it better to create a new project, or will there soon be a fix to this bug?

Likely the fix won’t be deployed for a couple weeks at least. I’m still not able to reproduce the sad face locally yet, so I’m not sure what the right work around is, but there is a good chance there is a work around with your existing project once we figure out exactly the cause of the error.

I cannot reproduce the ‘sad face’ either, and I’m not sure I will be able to. The error “Maximum file size in package is ~64k” is still occurring in my project. Do you see the same error after importing the game from here?

wonder-dude

I do see the error after importing however we’ve seen this error in the past and it hasn’t yet lead to a known problem. What was interesting about your instance was that it seemed it was causing game crashes or other problems.

It’s on our list to fix eventually but our current understanding was that this error didn’t directly cause problems and users could ignore it for now.

Then I will continue to edit the current project. If there is a problem in the future, I will let you know and make sure to take more screen shots :wink:

1 Like