Oops, there is a problem converting your code

Hi,

I’m making my first platform on arcade using the blocks and it keeps saying this ‘Oops, there is a problem converting your code.’. I have read the advice in a similar chat but I didn’t quite understand the advice.

Can you help?

Laura

hello @LJJames,
that can mean a few things in my experiences, some of them are,

  • Have you worked in blocks and then javascript (you might have done something wrong)
  • you might have an error, i would need a link to the game but the error would be in red
  • something else i’m forgetting

if you could send the link by going to
SHARE : PUBLISH PROJECT : COPY

also double check, sometimes you will name the var for the sprite (in this example its HERO). then if you go to set the position of the sprite it might do “MySprite” because this is the default name, you would have to change it to “HERO”(or the name) for it to work

keep creating and having fun!!

Thanks

  • Blobiy
1 Like

Hi Blobiy,

Thank you for helping me. I worked in blocks and I noticed that when I was working on the 4th level, the game stopped updating the simulator. I’ve checked it for errors and can’t see anything that jumps out but I’m new to this so probably missed it. I then tried to use the javascript to copy the game and found that it wouldn’t open in the form.

Any help would be really appreciated as I was really enjoying building the game.

My Game:

Thank you

Laura

Hello,
this i think i found the problem, but it was a bit weird.
this did not show up for me lined in red and i must have passed over it at least twice.

just put Alfie on the “is __ hitt…”
and it should be fine.
I would also like to say that your level design is very good, (and your cat is very cute)

I hope that you pursue this and have fun, also i would recommend one thing.
this recommendation is not about the game, but i would suggest that you save the link to a google docs, google slides(this is what i do), or any other online program that you know for sure that you can pull up.
this website can be finicky sometimes, and also it is fun to see you old game and then see how far you have come.

Thanks

  • Blobiy
1 Like

Also, im not sure if the quality is good enough, but i though a good addition was this when you check if your on the wall.

If you add a “and” to the whole thing, and make it a “not is down button pressed”
“and” and “not” are both in logic, and “is down pressed” is in the controller, but you will have to switch “A” (the default) to “down”.

This way you can fall if you choose to, i think this would make level three easier because some of those spaces are hard to get through.

Thanks

  • Blobiy
1 Like

Hi Blobiy,

Thank you so much for your help. I have added your suggested changes into my code but it is still saying the same thing ‘Sorry, we are unable to convert this program.’ It will not load anything above level 3. When I get to the end of level 3 it runs the ‘win’ code instead of moving on to to level 4. It’s really strange. Have I some how written too much code?

I have also followed your advice and backed everything up on to google drive. That was a great idea! I’ve even cleared my arcade projects and tried loading the game again but that hasn’t worked.

It is really frustrating as I was really enjoying building the levels. I’m keen to keep going and have lots of ideas.

Is there anything else I can do?

Laura

really weird bug (in makecode, not your project; filed it here: https://github.com/microsoft/pxt-arcade/issues/1844).

Somehow one of the blocks in the program got messed up, and it broke the whole thing. https://makecode.com/_g1XLrkT80PUd should work (there were a few unused blocks floating around at the bottom that I removed that ‘fixed’ it). I also fixed the missing block @Blobiy mentioned (also thanks for helping by the way @Blobiy ! I was too busy playing animal crossing all day to check till now :slight_smile:) and added a few walls to make sure things seemed to be working.

Love the art by the way, Alfie is adorable. @darzu ^^ game based off your videos

Thank you so much!! I can’t wait to continue building. I wouldn’t have been able to continue without either of your help.

Thank you for the lovely ‘Alfie’ comments as well.

Laura

1 Like

Ok, i saw them too and threw them away, then I saw the other block missing, i thought it was the missing block was the thing that was wrong! I thought that the blocks that were //-ed out. wait, so how did it work?

Yeah, disabled blocks shouldn’t affect the rest of the program, but somehow the mySprite.image block seems to have had a broken internal representation that caused building the game to fail. The reason the game was still showing up was that the last working version was still saved (as the bug happened in a slightly weird spot). (If you’re curious, in JavaScript mode there is an explorer for all files, and under built there is a .js file that is the thing that runs in the simulator - it’s not particularly human readable though, as things are generated to match the code that runs on hardware)

This should be fixed in the latest beta arcade.makecode.com/beta

Thank you, this seems to work. :love_you_gesture:t2:

Interesting, we have been coding the same type of platform games in school and my class’ platforms have been experiencing the same issue.

Laura

I was originally having this same problem. When I read through this, I tried to look and see what the problem was. I then tried to refresh the page. When I did that, most of my code got deleted and i was unable to undo it, even though the project had been previously saved. What do I do?