Is Rpi 3A+ really supported?

I’m desperately trying to get Makecode Arcade to work with Raspberry Pi 3A+.

First with McAirpos in RetroPie, witch didn’t work, since I needed to write chmod +w in the makecode folder for every new game. It did’n work with the screen either (a HD 1920*1080. The screen was distorted).

Then now, I tried to ONLY use the arcade-cardboard-rpi-3a-plus.zip file to just get makecode to work, but it says “cant open ‘/tmp/ptx-pid’:no such file or directory”.

If Rpi 3A+ isn’t supported any longer, maybe you should remove it?

I really wanted to get both RetroPie and Makecode to work as I am going to have som kids build their own cabinets, and one of them already have coded a makecode game, and it would have been so much fun to make it possible for him to play it on his own arcade :frowning:

I’ve been looking for an excuse to run MakeCode Arcade games on my a Raspberry Pi. :smiley:

I started with my Raspberry Pi Zero WH. I have this neat, wooden case from C4Labs. (It’s called the Zebra Zero Plus, if you’re interested.) I didn’t have any microswitch buttons handy, so I stopped by my local Radio Shack store and picked up a few. (Yes, we still have a Radio Shack in our area.) I followed the guide on the MakeCode Arcade documentation site, put the software on an SD card, et voilà! (In the photo, you can see the Raspberry Pi 3A+ anxiously awaiting to get in on the action.) I even loaded Crazy Tennis! onto the device via USB. Works like a champ!

After confirming that the buttons and wiring worked properly on a Raspberry Pi Zero, I connected the wires to the GPIO on my Raspberry 3A+. After swapping out the software (the 3A+ uses different software), I hooked up the 3A+ to my monitor, and it worked almost the same as the Zero. The kit that I bought at Radio Shack even had the elusive USB-A-to-USB-A cable, so I could load games on it via USB just like with the Zero!

The only thing that I couldn’t figure out was how to reset the device to get back to the menu and select a new game. I had to power down the 3A+. Once I reapplied power, I was taken back to the menu, complete with any games that I loaded via USB.

So, I can confirm that the guide and the software do indeed work with a Raspberry Pi 3A+. I now have an excuse to get a Pimoroni PiCade … or maybe I’ll just build a cabinet myself. :smiley:

Great way to spend a rainy Saturday afternoon!

1 Like

Great! It’s so much fun when it finally works :slight_smile: I also got my zero to work previously, but now I am stuck on my RPi 3 A+ which just don’t seem to work. I’m having more luck with the McAirpos script, than the makecode (but still with Ptx-Pid problem).

I downloaded the makecode script from the adafruit page and followed all steps, like I did for the pi zero, but there’s still the ptx-Pid problem :frowning: I wonder why I’m the only one having theese problems :frowning:

If you want more challenges - buy an usb encoder and connect instead of the GPIOs :smiley: Tthe more of us that test it, the better guides we can make for kids that want to build their own arcade :slight_smile:

1 Like


I am sorry, @sofiania, but I am neither able to reproduce your situation with missing write permissions on downloaded game files, nor have I found any way to get executable permissions directly on any files downloaded from the internet.

  1. For getting at least rw-r-r on downloaded game .elf files, please verify or set your downloads folder to rwx-rx-rx (755) and that your umask command returns 0022, which is fairly common.
  2. When copying to /home/pi/RetroPie/roms/makefile, please check that also this folder itself has rwx-rx-rx permissions and ownership pi:pi;
    chmod -R 755 /home/pi/RetroPie/roms/makecode&&chown -R pi:pi /home/pi/RetroPie/roms/makecode
    It should the preserve at least the necessary permissions from the source file when copying.
  3. When copying new game .elf files to the makecode game folder, please remember to set executable permissions before(chmod 755 ./game_file.elf) or after(chmod -R 755 /home/pi/RetroPie/roms/makecode) copying it to the makecode game folder.

Or, just use the rsync or install commands shown in the attached image above, which should solve both your write and executable permissions problems in the one and same command.

If anyone knows about other (secure)ways to immediately get executable permissions when downloading or uploading makecode game .elf files to the makecode game folder, please give us a wink.

To the best of my knowledge, lacking executable permissions is a (security)feature and not a bug, and your challenge with both the required write and executable permissions are solved quickly with 2 short commands or with 1 of 2 a little longer commands when getting new games.

Could you please explain to me why you experience this chmod/security issue as a problem or something that “didn’t work” with McAirpos, when you have to enter some command to copy/download/upload a new game to the makecode game folder every time anyways, regardless of what system you are using? :wink:


Regarding your screen issue, that shouldn’t have anything to do with McAirpos either, since its launCharc command just executes the game_file.elf natively as-is. But you could of course verify this by executing the game directly from the Linux command line yourself and please report back if there is a different result. (to exit the game that hangs when executed like this, press a combination of CTRL+C and CTRL+D to get back to the command line).

1 Like

Maybe we can help you diagnose the problem … although the error message that you’re reporting does seem a bit strange. Can you post a photograph of the 3A+'s screen with that error message? Maybe something in the kernel messages will help us diagnose the problems you’re encountering.

Ok, so the issue with permission to the folders (ptx-PID) with McAirpos was only when i used ftp (ssh) to transfer .elf files to the makecode folder. When I use a USB stick everything is fine…

1 Like

@Vegz78 on that post