Issue with

is there anyone that can help me with the issue i am having with the the issue i get when i start a code i get (cannot read properly ‘Kinda’ of undefined) attach is a small code that i copy from one of adafruit site and try to test it. attach is the image issue.

other issue as well.

@mmoskal error looks like the compiler issue we fixed for esp32

im really new at python and coding. is there something i need to do to fix this?

The program works for me in current maker (0.11.38). Can you press “Share” and share the link to the failing program here? (this is regarding the original issue)

here is the shared link.

Looks it is fixed. What browser are you on and version of maker?

i used Chrome 77.0.3865.120, Firefox 69.0.1, Explorer 11.418.18362.0, and MS Edge 44.18362.387.0. all gave me the same issue. running windows 10 enterprise

Go to the bottom of the home screen and click about to see the maker version.

MakeCode Maker (Cortex class) version: [0.11.41]

Microsoft MakeCode version: [5.25.13]

codal-circuit-playground runtime version: [v2.0.1]

so guessing no help here as well.

I just tried the first piece of code and it works ok inthe editor and makes a .UF2 file. This is using Chrome against

MakeCode Maker (Cortex class) version:  0.11.43

Microsoft MakeCode version:  5.26.4

codal-circuit-playground runtime version:  v2.0.1

Actually, one interesting difference is the show animation block is controlling a second array of NeoPixels in mine, they appear in the simulator on D2 pin:

I’ve seen the show animation block used for the Circuit Playground Express with its built-in ring of 10 mini NeoPixels. I don’t know how it functions on the Gemma M0 which has a single mini DotStar (not a NeoPixel) on the board? Is the expectation here that creating a variable called strip makes it work with show animation? [Added later] Oh, I see this was fixed in the second version of the code.

Might be worth starting a new project with a new name and re-creating it to see if this still doesn’t work?

BTW, 30 NeoPixels at full brightness (50-60mA) is 1.5A-1.8A.

I put in GH: microsoft/pxt-maker: On Gemma M0 using code for the on-board RGB LED also creates external LED strip in simulator #260 to deal with some of weirdness here.

Please send a screen recording of your issue. We cannot repro it.

here is the video…

Thanks the video helps a lot. The grey block means our decompiler wasn’t able to translate the python code into blocks (it’s a bug). It shows up as a grey JavaScript block because the conversion goes python -> javascript -> blocks. Still something we need to work on.

im looking for a code to do rainbow colors for RGB LED lights. is there a site you know of that i can get a code for it? until this bug is fixed?

The bug is due to rountripping to python. Stay in blocks for now.

the issue i have is i cant pair my device to the web and dont know how so thats why i wanted the code so i can copy and past.

ok so i got connected but when i try download the .uf2 onto board the board dissconnects and bricks the gemma. i have an old uf2 i download to update gemma to 4.0 and fix brick but can do maker.makecode