Microsoft MakeCode

MakeCode offline app: can't "download" files any more

On one of our computers the make code offline app has stopped working as expected. When you click the download button the button changes to a spinner icon and we never get the save dialog box. we have tried rebooting, resetting, re-installing, and deleting all files from documents and data. nothing seems to fix the issue. It was working fine one minute and the next download it stopped working. Is there any registry keys that I should look at fiddling with? The web app still works on the same PC. OS is Windows 10 (1903). Everything else seems to work fine just can’t actually have it create a UF2 file.

I am assuming this windows. On windows can you zip and send us this folder %APPDATA%\makecode_ev3? Example: C:\Users\abchatra\AppData\Roaming\makecode_ev3

Try the following:

  1. Uninstall MakeCode for EV3
  2. Backup and delete the above folder %APPDATA%\makecode_ev3
  3. Install MakeCode for EV3

This should solve the issue. If not let us know.

Also can you let us know your drive names when you have EV3 connected?

Ok I’ll get the zip here shortly. I had already did an uninstall then deleted everything that was left in %APPDATA%\makecode_ev3 but I’ll try again.

At the time I was just clicking the download button and saving locally without an EV connected at all. I also then tried connecting the EV via USB and that didn’t help.

P.S. would be nice to not see they how to connect your EV every time I download without it connected :slight_smile:

OK I think I didn’t delete the roaming folder just the app install dir. I’ll send the zip directly to you.