Skillmap/Tutorial editor not loading

Hi all,

My learning tech classes have been thrown into another round of remote learning and I have been using MakeCode to keep them engaged with some coding. Out of nowhere, the interface for my MakeCode Arcade seems to have stopped working and I can no longer load any projects. The site works fine until I try to launch into the editor.

It appears to be loading a frame inside a frame but, whatever the issue, the projects are not loading and I am stuck at a screen such as my screenshot below

Oddly, this is also only happening on a certain chrome profile. When I am using another browser or even a different Chrome profile on the same on computer everything works fine.

If I chose a new project then the editor loads fine. If I choose any of the skillmaps, or tutorials I get the issue.

I have tried deleting cache, cookies, etc. etc. etc. and nothing seems to work.

Help! (and thanks in advance)

Do you know if you have a GitHub account connected to on profile it isn’t loading on?

Welcome to the forum/community! Have you tried restarting your computer? I know it probably won’t work but if you haven’t, it’s worth a try (make sure you have backups of projects as it might delete them (I’m not sure) Also, you could, after you’ve backed up any projects you want to keep, go to the me.nu where you can see all of your projects and click the gear, then reset. DO THIS ONLY IF YOU HAVE THE PROJECTS BACKED UP AS IT WILL DELETE ALL PROJECTS. This resets makecode for this account and might correct some error (although I’m not to knowledgeable about how makecode reset works). These might work, but if they don’t, and switching chrome profiles works, then you can just switch chrome profiles, or switch to Microsoft Edge (as chrome isn’t too secure).

Ah, oh no! Could you press ctrl + shift + J and then copy paste everything in that console to the forums? (Hopefully it isn’t too long, haha.)

After that, you could try going to the Application tab in the console sidebar, clicking on Storage, then Clear site data (note that like Kiwiphoenix mentioned, this will delete all projects, skillmap, and tutorial progress):

Hi there. I tried this and it sadly did not work! Still the same. It’s bizarre how this only impacts one of my Chrome profiles!!! Going nuts tying to figure it out.

I do not have a GitHub account on this profile. Curious to know how it might impact?

Ahh that’s extremely odd, yeah! We store a bunch of information in the cache so it seemed possible that some data got corrupted in one profile while the others with clean data could still load, but a hard reset would usually have fixed things. Were you previously logged in to MakeCode when it stopped loading? If you open up the console (right click + Inspect, then switch to the Console tab), are there any errors?

If you save it with GitHub then it doesn’t save it from makecode and the local storage and instead save it in the GitHub servers.

Hi and sorry for the delay! It’s been a long Chinese New Year break here in Hong Kong!

No errors in the console but I do notice that it has been flagged as being in Quirks mode and this could be causing an unsual layout. Would this be the case?

Full info below:

  1. One or more documents in this page is in Quirks Mode, which will render the affected document(s) with quirks incompatible with the current HTML and CSS specifications.

Quirks Mode exists mostly due to historical reasons. If this is not intentional, you can add or modify the DOCTYPE to be <!DOCTYPE html> to render the page in No Quirks Mode.

  1. AFFECTED RESOURCES

  2. 1 element

1. |Document in the DOM tree|Mode|URL|

| — | — | — |
|document|Quirks Mode|https://arcade.makecode.com/–skillmap|

Ah okay, the saving is not the issue her but more the weird layout that is nesting the windows in a way that makes nothing work!